Update to 1.9.4

Hello friends!  We have now updated the server to 1.9.4 compatibility with the latest Spigot version.  As always, if you have any troubles at all on the server, please let me know!

Leave a Reply

Your email address will not be published. Required fields are marked *

*